help fix my speedo
21-10-2011, 12:21 PM,
#1
help fix my speedo
Hi all

just wondering if anyone on here is cluey enough to help me diagnose my speedo issue

I have a 1993 80 series 4.5 petrol

The speed reads double what it should

The VSS vehcile speed sensor is known to be workinng - tried it in my other 80 series.

The dash might be the issue but I dont want to pull my ther 80 apart yet to swap dashes.

I'm thinking it could be the cabling from the VSS to dash, Who can help me track it and test it?

Its just three wires, but I lose them once they go up n over the gearbox cant see where they go.
Reply
21-10-2011, 09:08 PM,
#2
Re: help fix my speedo
Matt

From memory it's the same as my Troopy,

Basically the pick up sends pulses that are driven by a gear that is connected to the transfer case output, the cable should head up to the ECU then on to your instrument cluster, where the pulses drive the speedo and odometer.
Couple of questions,
Firstly is the odometer recording the correct distance or is it also recording twice the distance?
Secondly - other than the speed display is anything else playing up?
Reply
24-10-2011, 06:57 PM,
#3
Re: help fix my speedo
Hi Peter

Distance is ok.

its just the speed is wrong

nothing else is wrong

Other than the trip meter is broken, but I pulled it out and u can see it wont turn coz its cracked Sad

seeing as it reads distance ok i'd assume its the speedo itself?
Reply
24-10-2011, 08:23 PM,
#4
Re: help fix my speedo
Oh Bugger

I guess that means you will need a new instrument cluster...
I have been told this is a common fault and is due to cracks in the back plain,
If you are willing I could have a look at the cluster and see if there is anything obvious but it's clear you either need to fix or replace it.
Reply
25-10-2011, 09:11 AM,
#5
Re: help fix my speedo
i've pulled it out once already

its all coroded on the back, i think its probably caused the issue.


SO I dont know if its worthing trying to fix? mostly its just the green coating thats peeled off but all the copper tracks on the board are rusty. So i think its pretty much stuffed.


I might just end up buying a 2nd hand cluster they are only about $130-160

I probably should try my other 80s dash in first but its fairly like its the cluster.

I wonder what other model toyota used the same dash? I know the speed sensor was uses in surfs and costs about 50% of the price Wink

Same with things such as power window buttons, surf one was $100 80 series was nearly 150 and they are identical infact I have a surf one in now and it works fineSmile

Cheers
matt
Reply
25-10-2011, 09:00 PM,
#6
Re: help fix my speedo
Hi

It is possible to get a new back plane for the speedo, there is is a guy in Rockhampton that rebuilds them, I think... it is a VERY common fault hence the cost of replacement units - if they are available at all.

If you are after more information look up Plumb on the 4WDA forum he is in Rocky and knows the guy in question, Rocky is 4WD and Cruiser Heaven - I have never seen so many 4WD's in one place!
Reply
25-10-2011, 09:24 PM,
#7
Re: help fix my speedo
I'l prob end up just buying a 2nd hand cluster.. it has something like 3 months warranty

Cluster repairs are about $375 not worth it really I can get a 2nd hand one for about $130ish atm

Good chance it works, At least I keep telling myself that
I guess if it fails withing 3 months I'll just try another, then another Smile
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)